Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Router na patyku
#1
Router on a stick - Router na patyku



Ponizsza konfiguracja przedstawia podsatwowa konfiguracje
Router na patyku (Router on a stick) to jeden ze sposobów na umożliwienie routingu między sieciami VLAN. Taka konfiguracja składa się z routera i przełącznika połączonych jednym łączem Ethernet skonfigurowanym jako łącze trunk 802.1q. Taka konfiguracja jest typowa w sieciach, w których nie istnieje przełącznik warstwy 3. Ale najpierw dowiedzmy się, dlaczego tak jest.

Podinterfejsy


Konfigurując nowe sieci VLAN na portach przełącznika, dzielimy domenę rozgłoszeniową, w której został on umieszczony, na mniejsze sekcje ograniczone do sieci VLAN. Podstawowy przełącznik nie może routować pakietów między domenami rozgłoszeniowymi. Powszechnie wiadomo, że router jest urządzeniem, które kieruje pakiety i rozdziela domeny rozgłoszeniowe.

Aby umożliwić komunikację między urządzeniami z różnych sieci VLAN, wymagane jest zatem rozwiązanie warstwy 3 modelu OSI. Jednym z przykładów jest router na patyku (który omówimy w tym materiale), ale istnieją również rozwiązania takie jak SVI (wirtualny interfejs przełącznika) lub jeden interfejs routera na VLAN.

Podinterfejs jest kluczową cechą routera na pendrive. Jest on konfigurowany dla każdej sieci na routerze.

Podinterfejsy są logicznymi elementami fizycznego interfejsu. Dzięki takiemu podejściu nie jest konieczne korzystanie z N fizycznych interfejsów routera w N sieciach VLAN. Zamiast tego istnieje łącze magistrali między przełącznikiem a routerem, więc oznaczone pakiety trafiają do routera. Następnie router usuwa etykiety i wyświetla podgląd tablicy routingu.

Konieczne jest skonfigurowanie enkapsulacji 802.1Q na każdym podinterfejsie i odpowiedniego znacznika VLAN, ponieważ po dopasowaniu wpisu pakiet jest enkapsulowany zgodnie z metodą skonfigurowaną na interfejsie wyjściowym.


Konfiguracja router na patyku



Załóżmy, że mamy sieć z dwoma komputerami w różnych sieciach VLAN. Mamy sieci VLAN 10 i VLAN 20. Aby umożliwić komunikację między PC1 z VLAN 10 i PC2 z VLAN 20, możemy użyć routera na patyku. Topologia wygląda następująco:

[Obrazek: DC-router-on-a-stick.png.webp]


Zacznijmy od skonfigurowania portu łączącego przełącznik z routerem. Należy pamiętać, że połączenie między routerem a przełącznikiem musi być skonfigurowane za pomocą łącza trunk:

Cytat:Switch#configure terminal
Switch(config)#int Fa0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#spanning-tree portfast trunk

Następnie utwórzmy wymagane sieci VLAN i skonfigurujmy porty dostępowe dla DTE:

Cytat:Switch#configure terminal
Switch(config)#vlan 10
Switch(config)#vlan 20
Switch(config)#int Fa0/2
Switch(config-if)switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int Fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

Na koniec rozpoczynamy konfigurację routera od ustawienia podinterfejsów. Na porcie łączącym router z przełącznikiem konfigurujemy podinterfejsy dla każdej sieci VLAN.

Ustawiamy również enkapsulację 802.1Q z numerem VLAN, do którego będzie należał podinterfejs. Podinterfejsy są logiczną instancją fizycznego portu Gig0/0 (w tym przypadku). Adres IP jest następnie przypisywany z puli dla określonej sieci VLAN.

Cytat:Router(config)#interface GigabitEthernet0/0.1
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 10.1.10.200 255.255.255.0
Router(config-subif)#interface GigabitEthernet0/0.2
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 10.1.20.200 255.255.255.0
Router(config-subif)#int Gig0/0
Router(config-if)#no shutdown


Maciej T.
Odpowiedz
#2
Polecam przed kontynuacja zapoznac sie z historia VLAN - dokument mozna otworzyc, pobrac stad : TUTAJ


II Scenariusz "router na patyku" (4.2.1) z utworzeneim menagement vlan do jego zdalnej konfiguracji ( obcji dostepu )

[Obrazek: 04fig05.jpg]

[/b]W poprzedniej sekcji wymieniono trzy sposoby tworzenia routingu między sieciami VLAN i szczegółowo opisano starszy routing między sieciami VLAN. W tej sekcji szczegółowo opisano sposób konfigurowania routingu między sieciami VLAN typu router na pendrive. Na rysunku widać, że router nie znajduje się w środku topologii, ale zamiast tego wydaje się być na patyku w pobliżu granicy, stąd nazwa.

Na rysunku 4-5 interfejs R1 GigabitEthernet 0/0/1 jest podłączony do portu S1 FastEthernet 0/5. Port S1 FastEthernet 0/1 jest podłączony do portu S2 FastEthernet 0/1. Są to łącza trunkingowe, które są wymagane do przekazywania ruchu w sieciach VLAN i między nimi.

[Obrazek: 04fig05.jpg]




Aby kierować między sieciami VLAN, interfejs R1 GigabitEthernet 0/0/1 jest logicznie podzielony na trzy podinterfejsy, jak pokazano w tabeli 4-2. W tabeli przedstawiono również trzy sieci VLAN, które zostaną skonfigurowane na przełącznikach.

Tabela 4-2 Podinterfejsy routera R1


PodinterfejsSieć VLAN Adres IP



G0/0/1.10  10          192.168.10.1/24

G0/0/1.20  20          192.168.20.1/24

G0/0/1.30  99          192.168.99.1/24




Załóżmy, że R1, S1 i S2 mają początkowe podstawowe konfiguracje. Obecnie PC1 i PC2 nie mogą pingować się nawzajem, ponieważ znajdują się w oddzielnych sieciach. Tylko S1 i S2 mogą pingować się nawzajem, ale są nieosiągalne dla PC1 lub PC2, ponieważ znajdują się również w różnych sieciach.

Aby umożliwić urządzeniom wzajemne pingowanie, przełączniki muszą być skonfigurowane z sieciami VLAN i trunkingiem, a router musi być skonfigurowany do routingu między sieciami VLAN.

Konfiguracja sieci VLAN i trunkingu S1 (4.2.2)

Wykonaj następujące kroki, aby skonfigurować S1 z sieciami VLAN i trunkingiem:

Krok 1. Utwórz i nazwij sieci VLAN. Najpierw tworzone są sieci VLAN i nadawane im nazwy, jak pokazano w przykładzie 4-1. Sieci VLAN są tworzone dopiero po wyjściu z trybu podkonfiguracji sieci VLAN.

Przykład 4-1 Tworzenie i nazywanie sieci VLAN



S1(config)# vlan 10
S1(config-vlan)# name LAN10
S1(config-vlan)# exit
S1(config)# vlan 20
S1(config-vlan)# name LAN20
S1(config-vlan)# exit
S1(config)# vlan 99
S1(config-vlan)# name Management
S1(config-vlan)# exit
S1(config)#

Krok 2. Utwórz interfejs zarządzania. Następnie interfejs zarządzania jest tworzony w sieci VLAN 99 wraz z bramą domyślną R1, jak pokazano w przykładzie 4-2.

Przykład 4-2 Tworzenie interfejsu zarządzania

S1(config)# interface vlan 99
S1(config-if)# ip add 192.168.99.2 255.255.255.0
S1(config-if)# no shut
S1(config-if)# exit
S1(config)# ip default-gateway 192.168.99.1
S1(config)#

Krok 3. Skonfiguruj porty dostępu. Następnie port Fa0/6 łączący się z komputerem PC1 jest konfigurowany jako port dostępu w sieci VLAN 10, jak pokazano w przykładzie 4-3. Załóżmy, że komputer PC1 został skonfigurowany z poprawnym adresem IP i bramą domyślną.

Przykład 4-3 Konfigurowanie portów dostępowych

S1(config)# interface fa0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config-if)# no shut
S1(config-if)# exit
S1(config)#

Krok 4. Skonfiguruj porty trunkingu. Na koniec porty Fa0/1 łączące się z S2 i Fa05 łączące się z R1 są skonfigurowane jako porty trunkingowe, jak pokazano w przykładzie 4-4.

Przykład 4-4 Konfigurowanie portów trunkingu


S1(config)# interface fa0/1
S1(config-if)# switchport mode trunk
S1(config-if)# no shut
S1(config-if)# exit
S1(config)# interface fa0/5
S1(config-if)# switchport mode trunk
S1(config-if)# no shut
S1(config-if)# end

Konfiguracja sieci VLAN i trunkingu S2 (4.2.3)
Konfiguracja dla S2 jest podobna do S1, jak pokazano w przykładzie 4-5.

Przykład 4-5 Konfiguracja S2



S2(config)# vlan 10
S2(config-vlan)# name LAN10
S2(config-vlan)# exit
S2(config)# vlan 20
S2(config-vlan)# name LAN20
S2(config-vlan)# exit
S2(config)# vlan 99
S2(config-vlan)# name Management
S2(config-vlan)# exit
S2(config)#
S2(config)# interface vlan 99
S2(config-if)# ip add 192.168.99.3 255.255.255.0
S2(config-if)# no shut
S2(config-if)# exit
S2(config)# ip default-gateway 192.168.99.1
S2(config)# interface fa0/18
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if)# no shut
S2(config-if)# exit
S2(config)# interface fa0/1
S2(config-if)# switchport mode trunk
S2(config-if)# no shut
S2(config-if)# exit
S2(config-if)# end

Konfiguracja podinterfejsu R1 (4.2.4)
Metoda routera na pendrive'ie wymaga utworzenia podinterfejsu dla każdej sieci VLAN, która ma być routowana.

Podinterfejs jest tworzony za pomocą komendy trybu konfiguracji globalnej interface interface_id.subinterface_id. Składnia podinterfejsu to interfejs fizyczny, po którym następuje kropka i numer podinterfejsu. Chociaż nie jest to wymagane, zwyczajowo dopasowuje się numer podinterfejsu do numeru sieci VLAN.

Każdy podinterfejs jest następnie konfigurowany za pomocą następujących dwóch poleceń:

encapsulation dot1q vlan_id [native]: To polecenie konfiguruje podinterfejs tak, aby odpowiadał na hermetyzowany ruch 802.1Q z określonego identyfikatora sieci vlan. Opcja natywnego słowa kluczowego jest dołączana tylko w celu ustawienia natywnej sieci VLAN na coś innego niż VLAN 1.

ip address ip-address subnet-mask: To polecenie konfiguruje adres IPv4 podinterfejsu. Ten adres zwykle służy jako brama domyślna dla zidentyfikowanej sieci VLAN.

Powtórz ten proces dla każdej sieci VLAN, która ma być kierowana. Każdy podinterfejs routera musi mieć przypisany adres IP w unikalnej podsieci, aby routing mógł wystąpić.

Po utworzeniu wszystkich podinterfejsów włącz interfejs fizyczny za pomocą polecenia konfiguracji interfejsu bez zamykania. Jeśli interfejs fizyczny jest wyłączony, wszystkie podinterfejsy są wyłączone.

W konfiguracji w przykładzie 4-6 podinterfejsy R1 G0/0/1 są skonfigurowane dla sieci VLAN 10, 20 i 99.

Przykład 4-6 Konfiguracja podinterfejsu R1



R1(config)# interface G0/0/1.10
R1(config-subif)# description Default Gateway for VLAN 10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# ip add 192.168.10.1 255.255.255.0
R1(config-subif)# exit
R1(config)#
R1(config)# interface G0/0/1.20
R1(config-subif)# description Default Gateway for VLAN 20
R1(config-subif)# encapsulation dot1Q 20
R1(config-subif)# ip add 192.168.20.1 255.255.255.0
R1(config-subif)# exit
R1(config)#
R1(config)# interface G0/0/1.99
R1(config-subif)# description Default Gateway for VLAN 99
R1(config-subif)# encapsulation dot1Q 99
R1(config-subif)# ip add 192.168.99.1 255.255.255.0
R1(config-subif)# exit
R1(config)#
R1(config)# interface G0/0/1
R1(config-if)# description Trunk link to S1
R1(config-if)# no shut
R1(config-if)# end
R1#

Sprawdź łączność między komputerami PC1 i PC2 (4.2.5)
Konfiguracja routera na pendrive'ie jest zakończona po skonfigurowaniu magistrali przełącznika i podinterfejsów routera. Konfigurację można zweryfikować z poziomu hostów, routera i przełącznika.

Na hoście sprawdź łączność z hostem w innej sieci VLAN za pomocą polecenia ping. Dobrym pomysłem jest najpierw zweryfikowanie bieżącej konfiguracji adresu IP hosta za pomocą polecenia ipconfig hosta systemu Windows, jak pokazano w przykładzie 4–7.

Przykład 4-7 Weryfikowanie konfiguracji hosta systemu Windows

Kod:
C:\Users\PC1> ipconfig
Windows IP Configuration
Ethernet adapter Ethernet0:
  Connection-specific DNS Suffix . :
  Link-local IPv6 Address          : fe80::5c43:ee7c:2959:da68%6
  IPv4 Address                     : 192.168.10.10
  Subnet Mask                      : 255.255.255.0
  Default Gateway                  : 192.168.10.1
C:\Users\PC1>

Wyjście potwierdza adres IPv4 i domyślną bramę PC1. Następnie użyj polecenia ping, aby zweryfikować łączność z komputerami PC2 i S1, jak pokazano na rysunku 4-5. Dane wyjściowe polecenia ping pomyślnie potwierdzają, że działa routing między sieciami VLAN, jak pokazano w przykładzie 4–8.

Przykład 4-8 Sprawdź routing między sieciami VLAN, wysyłając polecenie ping z komputera1

Kod:
C:\Users\PC1> ping 192.168.20.10 Ping 192.168.20.10 z 32 bajtami danych:
Odpowiedź z 192.168.20.10: bajtów=32 czas<1ms TTL=127
Odpowiedź z 192.168.20.10: bajtów=32 czas<1ms TTL=127
Odpowiedź z 192.168.20.10: bajtów=32 czas<1ms TTL=127
Odpowiedź z 192.168.20.10: bajtów=32 czas<1ms TTL=127
Statystyki pingów dla 192.168.20.10:
Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0 (0% straty).
Przybliżony czas podróży w obie strony w milisekundach:
Minimum = 0 ms, Maksimum = 0 ms, Średnia = 0 ms
C:\Użytkownicy\PC1>
C:\Users\PC1> ping 192.168.99.2 Ping 192.168.99.2 z 32 bajtami danych:
Upłynął limit czasu żądania.
Upłynął limit czasu żądania.
Odpowiedź z 192.168.99.2: bajtów=32 czas=2ms TTL=254
Odpowiedź z 192.168.99.2: bajtów=32 czas=1ms TTL=254 |
Statystyki ping dla 192.168.99.2:
Pakiety: Wysłane = 4, Odebrane = 2, Utracone = 2 (50% straty).
Przybliżony czas podróży w obie strony w milisekundach:
Minimum = 1 ms, Maksimum = 2 ms, Średnia = 1 ms
C:\Użytkownicy\PC1>


Weryfikacja routingu między sieciami VLAN typu router na patyku ( router on the a stick ) (4.2.6)
Oprócz korzystania z polecenia ping między urządzeniami, następujące polecenia show mogą służyć do weryfikowania i rozwiązywania problemów z konfiguracją routera na pendrive.

Pokaż trasę IP

Pokaż krótki opis interfejsu IP

Pokaż interfejsy

pokaż magistralę interfejsów

Jak pokazano w przykładzie 4–9, sprawdź, czy podinterfejsy są wyświetlane w tabeli routingu R1 przy użyciu polecenia show ip route . Zwróć uwagę, że istnieją trzy połączone trasy © i odpowiadające im interfejsy wyjściowe dla każdej routowalnej sieci VLAN. Dane wyjściowe potwierdzają, że prawidłowe podsieci, sieci VLAN i podinterfejsy są aktywne.

Przykład 4-9 Sprawdź, czy podinterfejsy znajdują się w tabeli routingu.

Kod:
R1# show ip route | begin Gateway
Gateway of last resort is not set
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, GigabitEthernet0/0/1.10
L        192.168.10.1/32 is directly connected, GigabitEthernet0/0/1.10
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, GigabitEthernet0/0/1.20
L        192.168.20.1/32 is directly connected, GigabitEthernet0/0/1.20
      192.168.99.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.99.0/24 is directly connected, GigabitEthernet0/0/1.99
L        192.168.99.1/32 is directly connected, GigabitEthernet0/0/1.99
R1#

Innym przydatnym poleceniem routera jest show ip interface brief, jak pokazano w przykładzie 4-10. Dane wyjściowe potwierdzają, że podinterfejsy mają skonfigurowany prawidłowy adres IPv4 i że działają.

Przykład 4-10 Weryfikowanie adresów IP i stanu podinterfejsu


Kod:
R1# show ip interface brief | include up
GigabitEthernet0/0/1   unassigned      YES unset  up                    up
Gi0/0/1.10            192.168.10.1     YES manual up                    up
Gi0/0/1.20            192.168.20.1     YES manual up                    up
Gi0/0/1.99            192.168.99.1     YES manual up                    up
R1#

Podinterfejsy można zweryfikować za pomocą polecenia show interfaces subinterface-id, jak pokazano w przykładzie 4-11.

Przykład 4-11 Weryfikowanie szczegółów podinterfejsu

Kod:
R1# show interfaces g0/0/1.10
GigabitEthernet0/0/1.10 is up, line protocol is up
  Hardware is ISR4221-2x1GE, address is 10b3.d605.0301 (bia 10b3.d605.0301)
  Description: Default Gateway for VLAN 10
  Internet address is 192.168.10.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.
  ARP type: ARPA, ARP Timeout 04:00:00
  Keepalive not supported
  Last clearing of "show interface" counters never
R1#

Błędna konfiguracja może również dotyczyć portu trunkingu przełącznika. W związku z tym przydatne jest również zweryfikowanie aktywnych łączy magistrali na przełączniku warstwy 2 za pomocą polecenia show interfaces trunk, jak pokazano w przykładzie 4-12. Dane wyjściowe potwierdzają, że łącze do R1 jest trunkingiem dla wymaganych sieci VLAN.

NUTA

Mimo że sieć VLAN 1 nie została jawnie skonfigurowana, została automatycznie uwzględniona, ponieważ ruch kontrolny na łączach magistralowych będzie zawsze przekazywany w sieci VLAN 1.

Przykład 4-12 Weryfikowanie stanu łącza magistrali


Kod:
S1# show interfaces trunk
Port        Mode             Encapsulation   Status        Native vlan
Fa0/1       on               802.1q          trunking      1
Fa0/5       on               802.1q          trunking      1
Port        Vlans allowed on trunk
Fa0/1       1-4094
Fa0/5       1-4094
Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,99
Fa0/5       1,10,20,99
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,99
Fa0/5       1,10,20,99
S1#

ŚLEDZENIE PAKIETÓW — KONFIGUROWANIE ROUTINGU MIĘDZY SIECIAMI VLAN ROUTERA NA URZĄDZENIU PRZENOŚNYM (4.2.7)








Ponizej wytlumaczone to na malej sieci VLAN 

https://www.ciscopress.com/articles/arti...7&seqNum=5
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości